W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2008

[selectors-api] Names of querySelector() and querySelectorAll() methods

From: Gavin Kistner <gavin@phrogz.net>
Date: Tue, 18 Nov 2008 21:32:23 -0700
Message-Id: <433FFA49-3AD2-4EDB-9045-4ADD8CEE9B5B@phrogz.net>
To: public-webapps@w3.org

I find these names rather cumbersome and not very self-explanatory.

Though it may be far too late for this suggestion, I would suggest  
that they should be something such as:

findNode()/findNodes() or findNode()/findAllNodes()
selectNode()/selectNodes() or selectNode()/selectAllNodes()
Received on Wednesday, 19 November 2008 04:33:02 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 October 2017 07:26:12 UTC