W3C home > Mailing lists > Public > public-webapps@w3.org > October to December 2008

Re: [selectors-api] Names of querySelector() and querySelectorAll() methods

From: Joćo Eiras <joao.eiras@gmail.com>
Date: Wed, 19 Nov 2008 19:53:10 -0000
To: "Gavin Kistner" <gavin@phrogz.net>
Cc: public-webapps@w3.org
Message-ID: <op.ukvtiwhhjz3wb9@umang>


Search the archives. There were long debates about naming.
In the end, the ones you see where choosen.

On , Gavin Kistner <gavin@phrogz.net> wrote:

>
> On Nov 18, 2008, at 9:32 PM, Gavin Kistner wrote:
>> I find these names rather cumbersome and not very self-explanatory.
>>
>> Though it may be far too late for this suggestion, I would suggest that  
>> they should be something such as:
>>
>> findNode()/findNodes() or findNode()/findAllNodes()
>> selectNode()/selectNodes() or selectNode()/selectAllNodes()
>> findBySelector()/findAllBySelector()
>
> Er, please replace all instances of Node with Element in the above.  
> Dunno what I was smoking.
>
> And 2 more:
> elementFromSelector()/elementsFromSelector()
>
>
Received on Wednesday, 19 November 2008 19:53:52 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 18:49:28 GMT