W3C home > Mailing lists > Public > public-webapi@w3.org > May 2008

[progress-events] loaded member misnamed?

From: Anne van Kesteren <annevk@opera.com>
Date: Wed, 28 May 2008 13:01:13 +0200
To: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.ubu177ky64w2qv@annevk-t60.oslo.opera.com>


Yesterday someone contacted me on IRC about implementing  
XMLHttpRequest.upload from XMLHttpRequest Level 2. It turns out that the  
Progress Events specification is not generic enough for both uploading and  
downloading as we agreed it should be long ago.

The ProgressEvent.loaded member should probably be defined in a more  
abstract way and I would actually suggest to rename it to  
ProgressEvent.transferred so it's clear that it is about transferred data.

(I also still feel that total and lengthComputable should be named in a  
more consistent way, e.g. total and totalKnown.)

Kind regards,

Anne van Kesteren
Received on Wednesday, 28 May 2008 11:01:10 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:27 UTC