W3C home > Mailing lists > Public > public-webapi@w3.org > July 2007

Re: [progress-events] stalled, lengthComputable, loadstart vs begin

From: Bjoern Hoehrmann <derhoermi@gmx.net>
Date: Wed, 25 Jul 2007 17:46:22 +0200
To: "Anne van Kesteren" <annevk@opera.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <anrea35lftla8bf9fnbetflc12d360rkb5@hive.bjoern.hoehrmann.de>

* Anne van Kesteren wrote:
>  * HTML 5 suggests "begin" as name for the first event rather than
>    "loadstart". I like "begin" better, but I care mostly about them
>    being the same.

We cannot call it 'begin' because that name and the easily confusable
name 'beginEvent' are already used in a number of implementations and
specifications for a distinct purpose. You would have to find a name
without this problem that works for both if you want them to be the
same, although that seems like a weird request to me (different events
should have different names, and the same event should be defined just
once, not several times).
Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de
Weinh. Str. 22 · Telefon: +49(0)621/4309674 · http://www.bjoernsworld.de
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/ 
Received on Wednesday, 25 July 2007 15:46:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:24 UTC