W3C home > Mailing lists > Public > public-webapi@w3.org > July 2007

Re: CSS Query API: selectorQuery(...)

From: Maciej Stachowiak <mjs@apple.com>
Date: Thu, 19 Jul 2007 18:13:43 -0700
Cc: public-webapi@w3.org
Message-Id: <CE50E9CA-BDE1-44C7-A431-1F3D197108C7@apple.com>
To: Bjoern Hoehrmann <derhoermi@gmx.net>


On Jul 19, 2007, at 10:07 AM, Bjoern Hoehrmann wrote:

>
> Hi,
>
>  The WebAPI Working Group is considering to conduct a poll to finally
> put the method naming issue in the CSS Query API specification to  
> rest;
> Charles asked us to propose alternatives to selectElement/ 
> selectAllEle-
> ments. To this end, I would like to propose using two [1] of
>
>  selectorQuery(...) / .selectorQueryAll(...) / .selectorQueryOne(...)

I second this proposal. I also propose:

querySelector() / querySelectorAll()
matchSelector() / matchSelectorAll()

Regards,
Maciej
Received on Friday, 20 July 2007 01:13:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:58 GMT