W3C home > Mailing lists > Public > public-webapi@w3.org > July 2007

Re: Selectors API Method Names

From: Maciej Stachowiak <mjs@apple.com>
Date: Mon, 2 Jul 2007 11:45:41 -0700
Message-Id: <B787D503-A3A7-48B0-9FD8-1DF77B32DAF8@apple.com>
Cc: public-webapi <public-webapi@w3.org>
To: Doug Schepers <doug.schepers@vectoreal.com>

On Jul 2, 2007, at 11:17 AM, Doug Schepers wrote:

> Hi-
> Maciej Stachowiak wrote:
>> I don't have a strong objection either way, but I think the case  
>> against Lachy's original names (selectElement, etc) has been laid  
>> out more clearly than the case against cssQuery. I think  
>> selectorQuery (as suggested in follow-ups) would also be ok.
> I think that the chief problem with cssQuery*() for me is that it  
> is rather confusing.  Such a name would indicate functionality  
> related to CSS (that is, something presentational or style- 
> oriented), rather than the accident of a historical relationship.   
> It totally fails the criteria of being functionally descriptive,  
> which selectElement() meets (other merits notwithstanding); this is  
> a point on which I think we can build consensus and compromise (and  
> hopefully a speedy resolution).
> Similarly, with selectorQuery() (which is better), you lose the  
> verby "action word" of the existing naming convention (getAByB);  
> selectorQuery sounds more like a property than a method.

querySelector or matchSelector or similar would keep the verb phrase  

Received on Monday, 2 July 2007 18:45:58 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:24 UTC