W3C home > Mailing lists > Public > public-webapi@w3.org > July 2007

Re: Selectors API Method Names

From: Jonas Sicking <jonas@sicking.cc>
Date: Mon, 02 Jul 2007 04:04:54 -0700
Message-ID: <4688DBD6.5080703@sicking.cc>
To: Charles McCathieNevile <chaals@opera.com>
Cc: Lachlan Hunt <lachlan.hunt@lachy.id.au>, public-webapi <public-webapi@w3.org>

Charles McCathieNevile wrote:
> 
> On Thu, 28 Jun 2007 12:20:37 +0200, Lachlan Hunt 
> <lachlan.hunt@lachy.id.au> wrote:
> 
>> Would others accept changing the methods to cssQuery() and 
>> cssQueryOne()?  If this would achieve concensus, I'd be willing to use 
>> these names.
> 
> Opera does not like the cssQuery names and prefers the names that were 
> suggested in Lachy's draft.
> 
> I recall strong objection to names which suggested this was about CSS in 
> the past (but maybe it was only Anne objecting) on the basis that this 
> isn't about CSS but selectors.
> 
> So, Bjoern, Maciej, do you object to closing the issue with the names 
> Lachy proposed in his draft, or are you just tossing in another idea in 
> case it gets stronger consensus?

I'm not really a big fan of anything containing 'css' either. But then 
again I don't think the length is as critical as many others seem to.

Admittedly I'm not a big fan of the selectElement/selectAllElements 
suggestions either for the reasons maciej raised (similarities to 
selectNodes/selectSingleNode).

How about selectorQuery/selectorQuerySingle/selectorQueryAll ?

/ Jonas
Received on Monday, 2 July 2007 11:05:02 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:57 GMT