W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API naming

From: Charles McCathieNevile <chaals@opera.com>
Date: Sat, 27 Jan 2007 20:36:54 -0500
To: "Maciej Stachowiak" <mjs@apple.com>
Cc: "Anne van Kesteren" <annevk@opera.com>, "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.tmub3svkwxe0ny@widsith.local>

On Sat, 27 Jan 2007 18:49:28 -0500, Maciej Stachowiak <mjs@apple.com>  
wrote:

> On Jan 27, 2007, at 7:25 AM, Charles McCathieNevile wrote:
>
>> On Fri, 26 Jan 2007 22:06:04 -0500, Maciej Stachowiak <mjs@apple.com>
>>> Congratulations, design by committee has once again failed to 
>>> meetanyone's requirements (in other words, I object to these names).
>>
>> Thanks. Your objection is noted, and will be forwarded on when we 
>> request the
>> transition to Last Call if these names are still there. In the meantime 
>> of course I look forward to your useful alternative proposal.
>
> That's hard to do without knowing why all the other proposals on the 
> table were ruled out. If the reasoning behind the decision is stated, I 
> will be happy to provide a suitable alternative, or to withdraw my 
> objection.

You have seen the minutes draft already (assuming everyone is happy with  
that it
will be available to the public in a week), and probably the raw IRC log.  
To
that I can only add that various working group members objected strongly  
to the
proposals for short names. There is a fair bit of rationale already on the
mailing list, but I would summarise it as

"they give no idea what they will do, are more likely to conflict with  
function
names in existing code that do other things, and if you want to shorten  
things
document.foo() is already a pain and you would write a wrapper even for  
that,
called get() or something".

As chair (and incidentally as Anne's manager at Opera, in which role I was
starting to be concerned about the amount of valuable time being spent on  
this)
my judgement was that we were not getting any hint that we would find  
consensus
in the working group to publish the specification with the short names Anne
proposed, and were dragging out the process a long and expensive time over  
a
relatively small issue.

In order to find a rough consensus we examined the various names which had  
been
proposed. getElementBySelector(s) was clearly the only one that didn't draw
violent objection for the singular method. After some back and forth and
reflection, getElementListBySelectors was chosen over  
getElementsBySelectors to
make it easier to pick out and debug, since it is a different kind of  
beast (list
instead of single element).

We would like feedback in particular on the choice of  
getElementListBySelectors
in this context. (That is noted in the minutes, but I don't think Anne's
original message really conveyed that little subtlety very well).

Note that there is also an issue about whether we need the singular method  
- if
we remove it, we may go with just getElementsBySelectors (giving my best  
guess
prediction at what would achieve easy consensus, not trying to prejudge the
outcome which will of course be decided by the working group, hopefully  
having
taken into account what the rest of the world has to say on the topic).

Others are welcome to add to this perspective of course - I am just  
presenting
it like I saw it as chair, and can't tell you the inner workings of other  
people's
minds...

cheers

Chaals

-- 
Charles McCathieNevile, Opera Software: Standards Group
hablo español - je parle français - jeg lærer norsk
chaals@opera.com Try Opera 9.1 http://opera.com
Received on Sunday, 28 January 2007 01:37:03 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT