W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Martijn <martijn.martijn@gmail.com>
Date: Wed, 20 Dec 2006 11:03:53 +0100
Message-ID: <6c97b8b10612200203s467b7fe3q2efafe2aeb57b7c4@mail.gmail.com>
To: "Anne van Kesteren" <annevk@opera.com>
Cc: "Dave Massy" <Dave.Massy@microsoft.com>, "Web API WG (public)" <public-webapi@w3.org>, "Chris Wilson" <chris.wilson@microsoft.com>, "Tina Duff" <tinad@microsoft.com>

On 12/19/06, Anne van Kesteren <annevk@opera.com> wrote:
> > 2. Naming
> > getElementBySelector/getElementsBySelector is the only proposal we think
> > is acceptable.
> But it's not accurate. This also creates the problem Ian Hickson pointed
> out a few times. That people will map it to $$ or something which makes it
> even less useful.

At least it's more accurate than match/matchAll/select or whatever
else was proposed.
And I believe people will map document.matchAll almost just as often
to $$ as document.getElementsBySelector.


Martijn Wargers
Help Mozilla!
Received on Wednesday, 20 December 2006 10:04:01 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC