W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Anne van Kesteren <annevk@opera.com>
Date: Fri, 15 Dec 2006 11:59:38 +0100
To: "Ian Hickson" <ian@hixie.ch>
Cc: "Dave Massy" <Dave.Massy@microsoft.com>, "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.tklktogd64w2qv@id-c0020>

On Fri, 15 Dec 2006 07:58:03 +0100, Ian Hickson <ian@hixie.ch> wrote:
> My only concern here is that we avoid the mistake that was made with
> getElementsByTagName and getElementById -- the names should be easy to
> type and short. I honestly think that if the one-item method is shorter
> than about 6 or 7 characters, then we've made a mistake.

You mean longer than?


> So I think "matchSelector" is too long. I think "matchSingle" is too  
> long. I think "select" and "match" are fine.

I'd love to use "select"...


> It doesn't matter what the words actually are. I think "aaaaa" is fine
> too (though it wouldn't be my first choice). As Maciej points out, we  
> just have to make sure we don't pick a name that makes everyone just  
> alias the
> method to $ or $$ or something equivalent.

Yeah, I agree with this.


-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>
Received on Friday, 15 December 2006 11:00:07 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT