W3C home > Mailing lists > Public > public-web-perf@w3.org > November 2010

Re: [NavigationTiming] Move window.performance to navigator.performance

From: Bryan McQuade <bmcquade@google.com>
Date: Tue, 23 Nov 2010 13:34:54 -0500
Message-ID: <AANLkTikgo7EJ-usVYHFyOr_+vBq+spvoPcNY=BTNusTb@mail.gmail.com>
To: Simon Pieters <simonp@opera.com>
Cc: public-web-perf@w3.org
Agree that the property name performance is likely to collide with existing
scripts. Maybe we need to choose a different less common name?
On Nov 23, 2010 5:12 AM, "Simon Pieters" <simonp@opera.com> wrote:
> Hi,
>
> I'm a bit concerned about
>
> http://test.w3.org/webperf/specs/NavigationTiming/#nt-window-performance
> [Supplemental]
> interface Window {
> readonly attribute Performance performance;
> };
>
> This adds a new property 'performance' to the global scope. I think there
> may be pages out there that already use that property for other things --
> script variables or <div id="performance"> or <a name="performance"> or
> <form onsubmit="return validate(performance.value)"><input
> name="performance">, and so forth.
>
>
http://google.com/codesearch?q=name%3D%28%22%7C%27%29%3Fperformance%28%22%7C%27%7C%5Cs%7C%3E%29+lang%3Ahtml
>
> To avoid polluting the global scope with a common name, potentially
> breaking scripts out there, I suggest we move the attribute to the
> Navigator interface.
>
>
http://dev.w3.org/html5/spec/timers.html#system-state-and-capabilities:-the-navigator-object
>
> To follow the convention around Navigator in HTML5 I guess it could look
> something like:
>
> [Supplemental, NoInterfaceObject]
> interface NavigatorPerformance {
> readonly attribute Performance performance;
> };
> Navigator implements NavigatorPerformance;
>
> --
> Simon Pieters
> Opera Software
>
Received on Tuesday, 23 November 2010 18:35:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 21 December 2010 18:13:56 GMT