W3C home > Mailing lists > Public > public-vocabs@w3.org > September 2014

Re: Schema.org proposal: New Actions and Actions contigent on an Offer

From: Jarno van Driel <jarnovandriel@gmail.com>
Date: Fri, 19 Sep 2014 10:12:03 +0200
Message-ID: <CADK2AU1_uVO24Qz6cq1uHS9-v3CF9hys13_OO+cyNNDnUCR8Dw@mail.gmail.com>
To: "martin.hepp@ebusiness-unibw.org" <martin.hepp@ebusiness-unibw.org>
Cc: ☮ elf Pavlik ☮ <perpetual-tripper@wwelves.org>, Vicki Tardif Holland <vtardif@google.com>, W3C Web Schemas Task Force <public-vocabs@w3.org>
Just to be sure, what about:

"@type": "Offer",
> "availability": "http://schema.org/False",


2014-09-19 10:10 GMT+02:00 martin.hepp@ebusiness-unibw.org <
martin.hepp@ebusiness-unibw.org>:

> I think this will not work, because you say that the Offer entity  is also
> an instance of "False". What you really want to do is negate the statement,
> not the single entity. Such would require reiification, e.g. something like
> a "Negation Role" for making such negative statements.
>
> One thing, though: In the current version of schema.org, False and True
> are subtypes of Boolean. They should be instances /  enumerated values.
>
> @Dan: It would be nice to fix that.
>
> Martin
>
> On 19 Sep 2014, at 00:24, Jarno van Driel <jarnovandriel@gmail.com> wrote:
>
> > Sorry for spamming - I'm toying around with it in my head- how about an
> MTE?
> >
> > {
> > "@context": "http://schema.org",
> > "@type": "WatchAction",
> > "target": "http://www.hulu.com/the­daily­show­with­jon­stewart",
> > "contingentOnOffer": {
> >       "@type": [ "Offer", "False" ],
> >       "availableAtOrFrom": {
> >               "@type": "Country",
> >               "name": "CHN"
> >       }
> > }
> >
> > 2014-09-19 0:18 GMT+02:00 Jarno van Driel <jarnovandriel@gmail.com>:
> > And maybe 'contingentOnOffer' can be renamed to something like
> 'dependsOnOffer'.
> >
> > As I'm not a native English speaker I had to look up what 'contingent
> on' first before I understood what it meant. So if you could 'dumb down'
> the term a bit I'd be much obliged.   :)
> >
> > 2014-09-19 0:10 GMT+02:00 Jarno van Driel <jarnovandriel@gmail.com>:
> > is 'notAvailableAtOrFrom' really needed, wouldn't the following work as
> well?
> >
> > Not Available in China
> >
> > {
> > "@context": "http://schema.org",
> > "@type": "WatchAction",
> > "target": "http://www.hulu.com/the­daily­show­with­jon­stewart",
> > "contingentOnOffer": {
> >       "@type": "Offer",
> >       "availability": "http://schema.org/False",
> >       "availableAtOrFrom": {
> >               "@type": "Country",
> >               "name": "CHN"
> >       }
> > }
> >
> > 2014-09-18 23:44 GMT+02:00 ☮ elf Pavlik ☮ <perpetual-tripper@wwelves.org
> >:
> > On 09/18/2014 10:43 PM, ☮ elf Pavlik ☮ wrote:
> > > On 09/17/2014 11:21 PM, Vicki Tardif Holland wrote:
> > >> And adding to Offer
> > >> http://schema.org/notAvailableAtOrFrom
> > > Whenever we change Offer I think we should check if it also makes sense
> > > for Demand. Also looking at name of this property @|@ I would propose
> > > considering some alternative solutions before committing to this one. I
> > > have some suggestions but would prefer to share them in github PR (or
> Issue)
> > I just suggested another pattern in:
> > https://github.com/rvguha/schemaorg/issues/125#issuecomment-56107865
> >
> >
> >
> >
> >
>
>
Received on Friday, 19 September 2014 08:19:50 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:29:44 UTC