W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

RE: [WebIDL] Simplify callbacks

From: Travis Leithead <travis.leithead@microsoft.com>
Date: Tue, 8 Nov 2011 18:04:14 +0000
To: Ojan Vafai <ojan@chromium.org>, Anne van Kesteren <annevk@opera.com>
CC: "public-script-coord@w3.org" <public-script-coord@w3.org>
Message-ID: <9768D477C67135458BF978A45BCF9B38381993E3@TK5EX14MBXW603.wingroup.windeploy.ntdev.microsoft.com>
FWIW, I like the idea. The current indirection through an interface annotated with [Callback] has historically been hard for newbies to WebIDL to figure out. Anne's concept helps reduce the indirection.

Another syntax could be:

addEventListener(DOMString type, [Callback(Event)] EventListener? listener, optional boolean capture)

Which re-uses the "constructor" parameter syntax (in an extended attribute) that we already have in WebIDL.

From: ojan@google.com [mailto:ojan@google.com] On Behalf Of Ojan Vafai
Sent: Tuesday, November 08, 2011 9:05 AM
To: Anne van Kesteren
Cc: public-script-coord@w3.org
Subject: Re: [WebIDL] Simplify callbacks

I support this. While it's not the API I'd design from scratch, I think it's what we're stuck with and the simplicity provided by doing this throughout the platform is worth it.
On Tue, Nov 8, 2011 at 6:47 AM, Anne van Kesteren <annevk@opera.com<mailto:annevk@opera.com>> wrote:
It seems that all callbacks use handleEvent() and we cannot change that at this point I think. We should simplify callback syntax to a) make IDL easier to read and b) ensure consistency throughout the platform.

addEventListener(DOMString type, Callback(Event)? listener, optional boolean capture)


--
Anne van Kesteren
http://annevankesteren.nl/
Received on Tuesday, 8 November 2011 18:04:55 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 May 2013 19:30:04 UTC