W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

Re: [WebIDL] Simplify callbacks

From: Ojan Vafai <ojan@chromium.org>
Date: Tue, 8 Nov 2011 09:04:49 -0800
Message-ID: <CANMdWTt1zXHrJFRy-S3JkEy4DNnvTkuMXMCNG8DiTvsXLZ_aBQ@mail.gmail.com>
To: Anne van Kesteren <annevk@opera.com>
Cc: "public-script-coord@w3.org" <public-script-coord@w3.org>
I support this. While it's not the API I'd design from scratch, I think
it's what we're stuck with and the simplicity provided by doing this
throughout the platform is worth it.

On Tue, Nov 8, 2011 at 6:47 AM, Anne van Kesteren <annevk@opera.com> wrote:

> It seems that all callbacks use handleEvent() and we cannot change that at
> this point I think. We should simplify callback syntax to a) make IDL
> easier to read and b) ensure consistency throughout the platform.
>
> addEventListener(DOMString type, Callback(Event)? listener, optional
> boolean capture)
>
>
> --
> Anne van Kesteren
> http://annevankesteren.nl/
>
>
Received on Tuesday, 8 November 2011 17:05:33 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 8 May 2013 19:30:04 UTC