W3C home > Mailing lists > Public > public-rdf-dawg@w3.org > April to June 2010

Re: Renaming sd:AggregateFunction

From: Gregory Williams <greg@evilfunhouse.com>
Date: Sun, 18 Apr 2010 14:58:11 -0400
Cc: SPARQL Working Group WG <public-rdf-dawg@w3.org>
Message-Id: <41E328D8-B8A7-4258-8EEC-FA89896876D1@evilfunhouse.com>
To: Steve Harris <steve.harris@garlik.com>
On Apr 18, 2010, at 2:56 PM, Steve Harris wrote:

> On 2010-04-18, at 19:38, Gregory Williams wrote:
>> Does anyone have thoughts on how that should be aligned with a renaming of sd:AggregateFunction to indicate that it's not really a function? Maybe we add a new property sd:extensionAggregate that is a subproperty of sd:feature?
> That makes sense to me - what's the range of sd:extensionFunction?

Right now it's sd:Function which had covered both scalar functions and aggregates. By making a new sd:extensionAggregate, we could then have the respective ranges be appropriately specific.

Received on Sunday, 18 April 2010 18:58:40 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:01:00 UTC