W3C home > Mailing lists > Public > public-rdf-dawg@w3.org > April to June 2010

Re: Renaming sd:AggregateFunction

From: Steve Harris <steve.harris@garlik.com>
Date: Sun, 18 Apr 2010 19:56:16 +0100
Cc: SPARQL Working Group WG <public-rdf-dawg@w3.org>
Message-Id: <81A9DA06-25CE-4975-AC03-0462401B2632@garlik.com>
To: Gregory Williams <greg@evilfunhouse.com>
On 2010-04-18, at 19:38, Gregory Williams wrote:
> So you could indicate that your endpoint supports a custom aggregate with:
> 
>> [] a sd:Service ; sd:extensionFunction ex:myAggregate .
> 
> 
> Does anyone have thoughts on how that should be aligned with a renaming of sd:AggregateFunction to indicate that it's not really a function? Maybe we add a new property sd:extensionAggregate that is a subproperty of sd:feature?

That makes sense to me - what's the range of sd:extensionFunction?

- Steve

-- 
Steve Harris, Garlik Limited
1-3 Halford Road, Richmond, TW10 6AW, UK
+44 20 8439 8203  http://www.garlik.com/
Registered in England and Wales 535 7233 VAT # 849 0517 11
Registered office: Thames House, Portsmouth Road, Esher, Surrey, KT10 9AD
Received on Sunday, 18 April 2010 18:56:46 GMT

This archive was generated by hypermail 2.3.1 : Tuesday, 26 March 2013 16:15:42 GMT