W3C home > Mailing lists > Public > public-qt-comments@w3.org > February 2004

[F+O] Rename component-from-duration() functions

From: Michael Kay <mhk@mhk.me.uk>
Date: Thu, 19 Feb 2004 12:26:33 -0000
To: <public-qt-comments@w3.org>
Message-ID: <000001c3f6e3$9cd48b90$6401a8c0@pcukmka>

I propose that we rename the functions:

years-from-yearMonthDuration
months-from-yearMonthDuration
days-from-dayTimeDuration
hours-from-dayTimeDuration
minutes-from-dayTimeDuration
seconds-from-dayTimeDuration

to

years-from-duration
months-from-duration
days-from-duration
hours-from-duration
minutes-from-duration
seconds-from-duration

without changing their signatures.

Firstly, the new names are shorter, which is a good thing in itself.

Secondly, I think we should anticipate at some stage (in v3.0)
supporting these functions on all durations, not only on the subtypes.
This naming change will make it easier to extend the domain of the
functions in the future.

Michael Kay 
Received on Thursday, 19 February 2004 07:25:52 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 5 February 2014 07:13:57 UTC