W3C home > Mailing lists > Public > public-qt-comments@w3.org > May 2003

F&O insert-before function

From: Priscilla Walmsley <priscilla@walmsley.com>
Date: Sat, 10 May 2003 07:50:24 -0400
To: <public-qt-comments@w3.org>
Message-ID: <000501c316ea$57e57640$030ba8c0@WALMSLEYPH>

I like the change of name from insert to insert-before.  However, the
rec currently says:

"The value returned by the function consists of all items of $target
whose index is less than or equal to N, followed by all items of
$inserts, followed by the remaining elements of $target, in that

Shouldn't that say just "less than N" rather than "less than or equal to
N"?  It seems the way it is worded, it should be named insert-after.

Also, it starts talking about "N" without introducing it in any way.  I
think this could be addressed by saying "...inserted at the position
N...." (i.e. adding the "N") in the first paragraph.

Received on Saturday, 10 May 2003 07:50:40 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:45:12 UTC