W3C home > Mailing lists > Public > public-qt-comments@w3.org > March 2003

XQuery 1.0 - Versioning in Query Prolog?

From: <Svgdeveloper@aol.com>
Date: Sat, 8 Mar 2003 17:14:54 EST
Message-ID: <156.1cd28616.2b9bc55e@aol.com>
To: public-qt-comments@w3.org

I wonder if it makes sense to add a component to the query prolog which 
indicates the version of XQuery that the query is being written in.

Presumably there will be XQuery 2.0 etc etc in due course.

In the short term I guess an XQuery processor assumes that if no version is 
specified then it is being asked to process XQuery 1.0.

Or is it time enough to consider versioning in the query prolog when XQuery 
1.5 or 2.0 or whatever is being drafted?

Andrew Watt
Received on Saturday, 8 March 2003 17:15:12 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 27 March 2012 18:14:24 GMT