W3C home > Mailing lists > Public > public-qt-comments@w3.org > December 2003

RE: [F&O] 15.1.8 fn:exists

From: Ashok Malhotra <ashokma@microsoft.com>
Date: Fri, 5 Dec 2003 08:53:16 -0800
Message-ID: <EDB607C8AC991F40BE646533A1A673E8C5A3C7@RED-MSG-42.redmond.corp.microsoft.com>
To: "Dimitre Novatchev" <dnovatchev@yahoo.com>, <public-qt-comments@w3.org>

Dimitre:
Thank you for your comment.  We discussed this on the 12/2/2003 telcon
and decided not to change the name of the function.  "empty" is as
imprecise a word as "exists" and it did not seem that a change in the
name of the function would benefit our users.

All the best, Ashok

-----Original Message-----
From: public-qt-comments-request@w3.org
[mailto:public-qt-comments-request@w3.org] On Behalf Of Dimitre
Novatchev
Sent: Saturday, November 22, 2003 5:09 AM
To: public-qt-comments@w3.org
Subject: [F&O] 15.1.8 fn:exists


There are two issues with this function:

 1.  The function name does not accurately reflect its semantic - it
does
     not provide an answer if a sequence exists, but if a sequence 
     is non-empty.

Because 
   
     not(empty($seq)) = exists($seq)

     a better name for this function would be notEmpty() or nonEmpty()

 2. The example in 15.1.8.1 is incorrect:

    "fn:exists($seq) returns true."

The above statement is true only if $seq is non-empty and $seq has not
been defined. One can incorrectly deduce that the function returns true
for any sequence.


Dimitre Novatchev.





__________________________________
Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/
Received on Friday, 5 December 2003 11:53:18 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 27 March 2012 18:14:28 GMT