W3C home > Mailing lists > Public > public-qa-dev@w3.org > June 2010

Re: Validator timeout and XML-LibXML bug

From: Dominique Hazael-Massieux <dom@w3.org>
Date: Fri, 11 Jun 2010 09:02:52 +0200
To: Ville Skyttä <ville.skytta@iki.fi>, ted@w3.org, jean-gui@w3.org, tgambet@w3.org
Cc: public-qa-dev@w3.org
Message-ID: <1276239772.11715.22.camel@localhost>
Le vendredi 11 juin 2010 à 01:34 +0300, Ville Skyttä a écrit :
> Candidate fix is now in CVS, seems to fix the problem on my box and qa-dev:
> http://dev.w3.org/cvsweb/validator/httpd/cgi-bin/check.diff?r1=1.776&r2=1.777
> (Needs also catalog.xml which is also in CVS).

Wow, thanks, you rock!

> I don't know how easy it would be port just this change over 0.8.6.

Ted, Jean-Gui, Thomas, could one of you take a look at preparing a new
release of the validator with that proposed fix? That bug explains both
the increased load on the validator, and a number of the recent bug
reports sent to www-validator.

> It may have been premature to drop support for non-structured errors, the 
> XML::LibXML docs still seem to indicate that non-structured ones may still be 
> thrown in some cases (no idea in exactly which) with 1.70, and if that's the 
> case, the above should be pretty much reverted.
> 
> Sigh.  The more I work with XML::LibXML, the less I like it :(

I'm hoping these are transient problems with that library rather than
structural ones; or are you thinking we should look into the possibility
of getting rid of that dependency altogether?

Dom
Received on Friday, 11 June 2010 07:03:02 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:51 GMT