W3C home > Mailing lists > Public > public-qa-dev@w3.org > August 2007

Re: Validator Bundle (Re: validator/misc/bundle/lib/Bundle/W3C Validator.pm,1.9,1.10)

From: Olivier Thereaux <ot@w3.org>
Date: Thu, 2 Aug 2007 08:31:04 +0900
To: QA-dev <public-qa-dev@w3.org>
Cc: bjoern@hoehrmann.de
Message-ID: <20070801233104.GA28539@w3.mag.keio.ac.jp>

On Mon, Jul 30, 2007, Ville Skyttä wrote:
> Yes.  The only tiny problem currently is that the validator 0.8.0 release 
> tarball contains the code that requires XML::LibXML >= 1.53, while the code 
> in CVS for both validator and the bundle has moved on and no longer has 
> version requirements for XML::LibXML.  I don't think it's a big problem 
> uploading the bundle without that versioned dependency though; if you agree, 
> I'll go ahead and do it.

Sure. Should be ok, I think.
 
> Hm, isn't it there already, or is the version there not suitable for 
> validator's purposes?  http://search.cpan.org/dist/SGML-Parser-OpenSP/
> 0.99 is what I'm using locally and shipping in Fedora, and the check script 
> has no version in its dependency to SPO (maybe due to the bug referred to in 
> below?)...

The validator won't work with any version under 0.99, because of some
bug fixed in that version. The problem is, if we require >= 0.99, the
now named 0.100 will be deemed too old by perl. I've been trying to
attract Bjoern and Terje's attention on this, but no reply so far.
Bjoern in Cc: here.

I guess it's fine to add SPO to the bundle without dependency. We can
always requires >= 0.99 when the version snafu is fixed.
 
> > Also, see:
> > http://sourceforge.net/tracker/index.php?
> > func=detail&aid=1694004&group_id=106431&atid=644086
> 
> My +1 to 1.00 :)

:)
 
-- 
olivier
Received on Wednesday, 1 August 2007 23:31:15 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:48 GMT