W3C home > Mailing lists > Public > public-qa-dev@w3.org > June 2004

Re: rewrite/pass-auth hack on qa-dev not working

From: Ville Skyttä <ville.skytta@iki.fi>
Date: Fri, 25 Jun 2004 01:14:55 +0300
To: QA Dev <public-qa-dev@w3.org>
Message-Id: <1088115294.27589.1475.camel@bobcat.mine.nu>

On Fri, 2004-06-25 at 00:46, olivier Thereaux wrote:
> On Jun 25, 2004, at 06:00, Ville Skyttä wrote:
> > I cannot get the mod_rewrite/pass-auth hack to work on qa-dev.  The
> > config is in /etc/apache2/conf.d/wmvs.conf, but whatever RewriteRule's
> > for the various check scripts I add there seem to be completely 
> > ignored.
> 
> Semi-random guesses: have you tried moving the rewrite directives 
> within the <Directory> for /wmvs?

Nope, but the hack isn't in <Directory> in my local setup either... will
try tomorrow but I guess this is not the culprit.

>  Also I think I remember that for 
> apache 1.3 the pass-auth hack only worked with specifically compiled 
> apache - is it the same for apache2?

I don't know about Apache 2, but in case you're referring to the
SECURITY_HOLE_PASS_AUTHORIZATION compilation option, httpd's built with
that will just pass the authorization info to CGI's, no further config
or rewrite hacks are needed.

> > v.w.o:8001 could possibly be used too
> 
> Waiting today for a potential solution... I can/will cvs up :8001 if 
> necessary then.

TIA.
Received on Thursday, 24 June 2004 18:14:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 August 2010 18:12:44 GMT