W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

RE: prov:value versus KeyValuePair

From: Evain, Jean-Pierre <evain@ebu.ch>
Date: Tue, 15 May 2012 19:01:33 +0200
To: 'Stephan Zednik' <zednis@rpi.edu>, Timothy Lebo <lebot@rpi.edu>
CC: Luc Moreau <L.Moreau@ecs.soton.ac.uk>, "public-prov-wg@w3.org" <public-prov-wg@w3.org>
Message-ID: <7D1656F54141C042A1B2556AE5237D600116304E61B0@GVAMAIL.gva.ebu.ch>
That's modern :--(

Sigh.edu

-----Original Message-----
From: Stephan Zednik [mailto:zednis@rpi.edu] 
Sent: mardi, 15. mai 2012 17:35
To: Timothy Lebo
Cc: Luc Moreau; public-prov-wg@w3.org
Subject: Re: prov:value versus KeyValuePair


On May 15, 2012, at 9:33 AM, Timothy Lebo wrote:

> Stephan and WG,
> 
> Given Luc's response about Dictionaries providing structure to Entities, can we go with pairKey and pairValue?

I think this is the best solution forward.

--Stephan

> 
> Any more concerns?
> 
> Thanks,
> Tim
> 
> 
> 
>>> Leaning towards Luc and Stephan, what about 
>>> 
>>> [ 
>>> a prov:KeyValuePair;
>>> prov:pairKey      "goalie"; 
>>> prov:pairValue  :joe_the_tank;
>>> ]
>>> 
>>> I think the property should be named by the role, not its range - otherwise we'd have pairString which is odd.
>> 
>> I think this goes back to my preference for prov:KeyEntityPair over prov:KeyValuePair.
>> 
>> Why can only entities be the value in a KeyValuePair?
>> 
>> --Stephan
> 
> 
> 
> 


------------------------------------------------------------------------------

**************************************************
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error, please notify the system manager. This footnote also confirms that this email message has been swept by the mailgateway
**************************************************
Received on Tuesday, 15 May 2012 17:02:42 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 15 May 2012 17:02:42 GMT