W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

From: Timothy Lebo <lebot@rpi.edu>
Date: Mon, 14 May 2012 14:29:39 -0400
Cc: Luc Moreau <L.Moreau@ecs.soton.ac.uk>, Jun Zhao <jun.zhao@zoo.ox.ac.uk>, public-prov-wg@w3.org
Message-Id: <2CD84F48-C27F-44A0-9513-D5F17C6B7033@rpi.edu>
To: Daniel Garijo <dgarijo@delicias.dia.fi.upm.es>
Daniel,

Although I don't share your misunderstanding on _this_ property, I can completely appreciate the frustration with a confusingly named property
(especially when the direction comes into question).

Personally, I'd like to keep wasQuotedFrom.

But in the interest of finding a compromise, I'm voting with weights between [-1,10]

On May 14, 2012, at 2:08 PM, Daniel Garijo wrote:

> Hi all,
> It seemed like there was not enough consensus in the telecon past thursday about the last proposal.
> If I remember correctly, Tim and Jun voted -1 for prov:wasAQuoteFrom.
> 
> So far, there have been the next proposals:
> quoted: there was no consensus because it could imply an agent instead of an entity.

-1
Yes, it would seem that, e.g. 
:daniel prov:quoted :PROV-DM .

> wasQuoteOf: we started with this definition, and moved away because it was confusing.

+0
It sort of reads "was part of", which I could live with.
Overall, I think it loses clarity (hence my suggestion to move away from it months back).

> hadQuoteFrom: there was no consensus because it could imply that the quotation is partial.

-1
I think we agreed that this changes the intended meaning, where the subject _contains_ a quote, but is not the quote itself.

> 
> wasAQuoteFrom: there was no consensus because "if it was a quote, then what is it now"?

-1
(like my vote last week, for the reason you mention)
Grounded in PROV, I think this insinuates that the invalidation time of the entity is earlier than the current time.

> isAQuoteFrom/isQuoteFrom: there has been no votes on this one, but it goes against having everything 
> in past tense.

+0
It loses the "past tense" pattern of the rest of the properties.
The directionality is obvious.

> wasQuotedFrom: the current name and the only one I have concerns about, because
> the directionality of the property is not clear enough.

+10
This reads extremely naturally for me.
It parallels its super property's name (wasDerivedFrom)
Parallels "wasTakenFrom", which shares the same concept.

> Just a small remark: the issue is about the name of the property. The definition on DM is very clear.
> 

Right, so adding domains, ranges, etc. does _not_ help move us towards a happy Daniel.

Regards,
Tim

> During today's prov-o telecon Tim said that he proposed to move away from wasQuoteOf in order
> to have something similar to wasDerivedFrom. I would be happy to go back to wasQuoteOf if there
> is no other suggestion.
> 
> Thoughts, Jun, Tim?
> 
> Thanks,
> Daniel
> 
> 2012/5/8 Luc Moreau <L.Moreau@ecs.soton.ac.uk>
> good idea, we'll put it on Thursday's agenda
> 
> 
> On 05/08/2012 03:20 PM, Daniel Garijo wrote:
>> 
>> Hi Luc,
>> I still think that the name could be improved because the current one is confusing.  
>> 
>> My last proposal ("wasAQuoteFrom") got a +1 from Stian and Paul 
>> (although he said he would think of a better name). Nobody else said anything, 
>> so maybe we should ask the rest of the group on thursday?
>> 
>> Best,
>> Daniel
>> 
>> 2012/5/8 Luc Moreau <L.Moreau@ecs.soton.ac.uk>
>> Hi Daniel,
>> 
>> I don't believe there was consensus to change the name of the relation as you suggested.
>> We also have removed agents from this definition. Definition of quote/original attributes
>> are as follows:
>> 
>> 
>> 
>> quote: an identifier (e2) for the entity that represents the quote (the partial copy);
>> original: an identifier (e1) for the original entity being quoted;
>> 
>> Can we close this issue?
>> Cheers,
>> Luc
>> 
>> 
>> On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
>> PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]
>> 
>> http://www.w3.org/2011/prov/track/issues/352
>> 
>> Raised by: Daniel Garijo
>> On product: prov-dm
>> 
>> Currently, the DM says:
>> A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs) in PROV-ASN, contains:
>>     quote: an identifier e2, identifying an entity record that represents the quote;
>>     quoted: an identifier e1, identifying an entity record representing what is being quoted;
>> ...
>> 
>> However, if we say that e2 wasQuotedFrom e1 it may look like entity e1 is the one quoting e2 (since we are saying that e2 was quoted).
>> 
>> I think it would be more clear if we rename the property with e2 wasQuoteOf e1, or e2 hadQuoteFrom e1.
>> 
>> Thoughts?
>> Thanks,
>> Daniel
>> 
>> 
>> 
>>   
>> 
>> -- 
>> Professor Luc Moreau
>> Electronics and Computer Science   tel:   +44 23 8059 4487
>> University of Southampton          fax:   +44 23 8059 2865
>> Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
>> United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
>> 
>> 
>> 
> 
> -- 
> Professor Luc Moreau               
> Electronics and Computer Science   tel:   +44 23 8059 4487         
> University of Southampton          fax:   +44 23 8059 2865         
> Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk  
> United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
> 
Received on Monday, 14 May 2012 18:41:23 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 14 May 2012 18:41:24 GMT