W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: PROV-ISSUE-338: explain prov:agent vs. prov:hadPlan naming convention [PROV-O HTML]

From: Stephan Zednik <zednis@rpi.edu>
Date: Wed, 2 May 2012 15:25:47 -0600
To: Provenance Working Group <public-prov-wg@w3.org>
Message-Id: <9009D5B1-7212-4EBD-AA06-7AEA8254033A@rpi.edu>
Hi Luc,

Did the explanation from my last email sufficiently explain the PROV-O naming conventions?

The PROV-O group discussed this issue on Monday and decided to update the online documentation and ontology annotations in an attempt to make the naming conventions more visible.

Is this issue ready to be closed?

--Stephan

On Apr 29, 2012, at 10:07 PM, Stephan Zednik wrote:

> See ISSUE-348 for a listing of current PROV-O naming conventions (http://lists.w3.org/Archives/Public/public-prov-wg/2012Apr/0201.html), but here is pretty much the same content for prov:activity vs prov:hadActivity (most interesting example) in my own words.
> 
> Properties from an Involvement or one of its subclasses that reference the the object of the equivalent unqualified relation are lowercase of the domain class - i.e. activity, agent, entity, dictionary.  These properties are all sub-properties of prov:involvee.  The property prov:activity has as its domain prov:ActivityInvolvement and would not be used with non-ActivityInvolvement qualifications.
> 
> Properties from an Involvement or one of its subclasses that do not reference the object of the equivalent unqualified relation utilize the prov:hadXXX naming convention where XXX is generally the class in the range of the property.  For example, prov:hadActivity has a domain the union of Derivation, Invalidation, and Responsibility.
> 
> This is the current naming conventions for hadXxx vs xxx to the best of my knowledge.  I would reference the PROV-O documentation, as I think we reference the naming convention in the latest draft, but the hosting server appears to be down right now. :-(
> 
> --Stephan
> 
> On Apr 9, 2012, at 7:55 AM, Provenance Working Group Issue Tracker wrote:
> 
>> PROV-ISSUE-338: explain prov:agent vs. prov:hadPlan naming convention [PROV-O HTML]
>> 
>> http://www.w3.org/2011/prov/track/issues/338
>> 
>> Raised by: Timothy Lebo
>> On product: PROV-O HTML
>> 
>> http://www.w3.org/mid/EMEW3|2c084c78f3361c61dff318d0c8aad9d6o339EE08L.Moreau|ecs.soton.ac.uk|4F7C02D3.7090705@ecs.soton.ac.uk
>> 
>> Hi prov-o team,
>> 
>> Just one more thoughts that came up when reading the primer.
>> 
>> Looking at the following snippet:
>> 
>> ex:correct prov:qualifiedAssociation [
>>              a Association ;
>>              prov:agent   ex:edith ;
>>              prov:hadPlan ex:corrections
>>          ] .
>> 
>> it is strange to see prov:hasPlan, why not simply prov:plan (and similarly
>> for other hadXXX properties).
>> 
>> Cheers,
>> Luc
>> 
>> 
>> 
>> 
> 
Received on Wednesday, 2 May 2012 21:26:18 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 2 May 2012 21:26:19 GMT