W3C home > Mailing lists > Public > public-prov-wg@w3.org > April 2012

Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

From: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
Date: Thu, 19 Apr 2012 14:43:45 +0100
Message-ID: <EMEW3|09481cde4b07a13c400b1dcb779b8f3eo3IEhm08L.Moreau|ecs.soton.ac.uk|4F901691.9040507@ecs.soton.ac.uk>
To: public-prov-wg@w3.org
Hi Daniel,

This is the current definition of quotation. Is there still a concern 
with it?

Cheers,
Luc

4.3.3 Quotation

A quotation is the repeat of (some or all of) an entity, such as text or 
image, by someone other than its original author.

Quotation is a particular case of derivation in which entity e2 is 
derived from an original entity e1 by copying, or "quoting", some or all 
of it. A quotation relation, written 
wasQuotedFrom(id,e2,e1,ag2,ag1,attrs) in PROV-N, has:

id: an optional identifier for the relation;
quote: an identifier (e2) for the entity that represents the quote (the 
partial copy);
original: an identifier (e1) for the original entity being quoted;
quoterAgent: an optional identifier (ag2) for the agent who performs the 
quote;
originalAgent: an optional identifier (ag1) for the agent to whom the 
original entity is attributed;
attributes: an optional set (attrs) of attribute-value pairs 
representing additional information about this relation.


On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
> PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]
>
> http://www.w3.org/2011/prov/track/issues/352
>
> Raised by: Daniel Garijo
> On product: prov-dm
>
> Currently, the DM says:
> A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs) in PROV-ASN, contains:
>      quote: an identifier e2, identifying an entity record that represents the quote;
>      quoted: an identifier e1, identifying an entity record representing what is being quoted;
> ...
>
> However, if we say that e2 wasQuotedFrom e1 it may look like entity e1 is the one quoting e2 (since we are saying that e2 was quoted).
>
> I think it would be more clear if we rename the property with e2 wasQuoteOf e1, or e2 hadQuoteFrom e1.
>
> Thoughts?
> Thanks,
> Daniel
>
>
>
>    

-- 
Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487
University of Southampton          fax:   +44 23 8059 2865
Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
Received on Thursday, 19 April 2012 13:44:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:07:03 GMT