W3C home > Mailing lists > Public > public-owl-wg@w3.org > April 2009

RE: Review of RDF Mapping

From: Michael Schneider <schneid@fzi.de>
Date: Wed, 8 Apr 2009 15:31:57 +0200
Message-ID: <0EF30CAA69519C4CB91D01481AEA06A0011DAA0F@judith.fzi.de>
To: "Boris Motik" <boris.motik@comlab.ox.ac.uk>, "Evren Sirin" <evren@clarkparsia.com>
Cc: <public-owl-wg@w3.org>

I want to concur with Boris here!

Every time we are resolving some change to the RDF mapping, I'm getting
busy, having paper and pencil and a copy of the current version of the
RDF-Based Semantics in my hands, getting myself a cup of coffee, and
starting to calculate whether there are any non-obvious semantic
consequences, e.g. concerning the consistency of OWL 2 Full or concerning
the correctness of the correspondence theorem. A particular change may seem
"natural" in the first place, but then turns out to have unexpected side
effects. Hence, such analysis work is generally non-trivial and takes me a
lot of time.

This has sometimes even been a joy job. However, looking at my watch, there
are less than *4 hours* left before we are going to vote our documents into
LC. So can we please stop these sorts of discussions NOW? There has been a
lot of time for these discussions within the last few months.

Concerning DatatypeDefinitionS in particular: I find it not unnatural to use
owl:equivalentClass for this purpose in OWL 2 Full (otherwise I would have
spoken up... before today :)). Clearly, one uses owl:equivalentClass for
writing definitions such as

  ex:C owl:equivalentClass ...SuperComplexClassExpression...

Now, a datatype restriction is a datatype, and thus is just another class in
OWL 2 Full. And as long as the LHS of such a definition-equivalence-axiom is
typed as a datatype, everything is fine for the RDF-Based Semantics. (I
could have introduce another semantic conditions of the form: "If one of the
two sides is a datatype, then the other is as well, but I didn't, since it
isn't necessary for the correspondence theorem to hold.) 


>-----Original Message-----
>From: public-owl-wg-request@w3.org [mailto:public-owl-wg-request@w3.org]
>On Behalf Of Boris Motik
>Sent: Wednesday, April 08, 2009 3:04 PM
>To: 'Evren Sirin'
>Cc: public-owl-wg@w3.org
>Subject: RE: Review of RDF Mapping
>Hello Evren,
>> >
>> >> Section 2.1:
>> >>
>> >> Intersection and union data ranges reuse class constructs
>> >> owl:intersectionOf and owl:unionOf keywords respectively whereas
>> >> datatype complement is expressed with owl:datatypeComplementOf.
>> >> Initially owl:complementOf was used for datatype complements but
>> >> was changed as a result of discussions on how it affects RDF-based
>> >> semantics [1]. AFAICT, the semantic problems related to complement
>> >> not occur for intersection and union. So from the point of
>> >> everything is OK. However, from the style point of view, the
>> >> vocabulary is inconsistent and possibly confusing. I think the
>> >> "datatype" prefix should be either used for all keywords or none.
>> >> Personally I'd be happy with none having the prefix but given the
>> >> semantics issue it might be to coin new terms for these datatypes.
>> >> Also in the past people expressed their discomfort about reusing
>> >> class vocabulary for datatypes due to forward compatibility reasons
>> >> [2] and similar reasons resulted in coining propertyDisjointWith
>> >> instead of using disjointWith for properties.
>> >>
>> >> The same arguments apply to DatatypeDefinition mapping which uses
>> >> owl:equivalentClass keyword. I think this is more confusing than
>> >> previous case since the name makes it clear that the keyword was
>> >> intended to be used for classes. Considering there is a
>> >> of amount of OWL users that use only RDF/XML, it would be better
>use a
>> >> less confusing name such as equivalentDatatype.
>> >
>> > In RDF, datatypes are classes, so in OWL 1 Full owl:unionOf,
>> > owl:intersectionOf, and owl:equivalentClass were already available
>> > use for datatypes, and appear to fit better into the RDF style.
>> I agree this is true for unionOf and intersectionOf but I don't think
>> it is good style in any means to reuse equivalentClass for datatypes.
>> It might have been available for datatypes in OWL 1 Full but clearly
>> it wasn't commonly used in that way (actually I don't know if it was
>> used for that purpose in practice at all). If this was a type neutral
>> term like equivalentTo I wouldn't object to its reuse. I understand
>> the time constraints for not making any changes right now but I the
>> reuse of equivalentClass should be reconsidered after LC. Considering
>> a lot of people coming from RDF world sees only the RDF view of OWL I
>> think it is important to provide clear, consistent RDF mapping that
>> does not lead to confusion.
>An important part of the "deal" when we decided to introduce datatype
>definitions was that there will be no change to the RDF-Based Semantics:
>for the
>solution proposed, the semantic conditions on owl:equivalentClass were
>sufficient. It is my understanding that the implementors of RDF-based
>are rather leery of extending the RDF vocabulary, and it is particularly
>case when existing vocabulary suffices. As a consequence, the existing
>is an extensively "negotiated" compromise between what the WG considered
>necessary, correct, and "beautiful".
>I am personally quite leery of reopening this can of worms, as it might
>have a
>significant impact on the WG schedule. This is particularly so given
>that the
>existing solution, while possibly being ugly, does work. Should you
>feel that we should revisit this decision, it would be really useful if
>could attend one of our teleconferences and "present your case".
>	Boris

Dipl.-Inform. Michael Schneider
Research Scientist, Dept. Information Process Engineering (IPE)
Tel  : +49-721-9654-726
Fax  : +49-721-9654-727
Email: michael.schneider@fzi.de
WWW  : http://www.fzi.de/michael.schneider
FZI Forschungszentrum Informatik an der Universität Karlsruhe
Haid-und-Neu-Str. 10-14, D-76131 Karlsruhe
Tel.: +49-721-9654-0, Fax: +49-721-9654-959
Stiftung des bürgerlichen Rechts, Az 14-0563.1, RP Karlsruhe
Vorstand: Prof. Dr.-Ing. Rüdiger Dillmann, Dipl. Wi.-Ing. Michael Flor,
Prof. Dr. Dr. h.c. Wolffried Stucky, Prof. Dr. Rudi Studer
Vorsitzender des Kuratoriums: Ministerialdirigent Günther Leßnerkraus

Received on Wednesday, 8 April 2009 13:32:40 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:42:11 UTC