W3C home > Mailing lists > Public > public-owl-wg@w3.org > April 2009

RE: Review of RDF Mapping

From: Boris Motik <boris.motik@comlab.ox.ac.uk>
Date: Wed, 8 Apr 2009 14:04:27 +0100
To: "'Evren Sirin'" <evren@clarkparsia.com>
Cc: <public-owl-wg@w3.org>
Message-ID: <C2FF50386E44477F8D075CC2985E3825@wolf>
Hello Evren,


> >
> >> Section 2.1:
> >>
> >> Intersection and union data ranges reuse class constructs
> >> owl:intersectionOf and owl:unionOf keywords respectively whereas
> >> datatype complement is expressed with owl:datatypeComplementOf.
> >> Initially owl:complementOf was used for datatype complements but this
> >> was changed as a result of discussions on how it affects RDF-based
> >> semantics [1]. AFAICT, the semantic problems related to complement do
> >> not occur for intersection and union. So from the point of semantics
> >> everything is OK. However, from the style point of view, the resulting
> >> vocabulary is inconsistent and possibly confusing. I think the
> >> "datatype" prefix should be either used for all keywords or none.
> >> Personally I'd be happy with none having the prefix but given the
> >> semantics issue it might be to coin new terms for these datatypes.
> >> Also in the past people expressed their discomfort about reusing
> >> class vocabulary for datatypes due to forward compatibility reasons
> >> [2] and similar reasons resulted in coining propertyDisjointWith
> >> instead of using disjointWith for properties.
> >>
> >> The same arguments apply to DatatypeDefinition mapping which uses
> >> owl:equivalentClass keyword. I think this is more confusing than the
> >> previous case since the name makes it clear that the keyword was
> >> intended to be used for classes. Considering there is a considerable
> >> of amount of OWL users that use only RDF/XML, it would be better use a
> >> less confusing name such as equivalentDatatype.
> >
> > In RDF, datatypes are classes, so in OWL 1 Full owl:unionOf,
> > owl:intersectionOf, and owl:equivalentClass were already available for
> > use for datatypes, and appear to fit better into the RDF style.
> I agree this is true for unionOf and intersectionOf but I don't think
> it is good style in any means to reuse equivalentClass for datatypes.
> It might have been available for datatypes in OWL 1 Full but clearly
> it wasn't commonly used in that way (actually I don't know if it was
> used for that purpose in practice at all). If this was a type neutral
> term like equivalentTo I wouldn't object to its reuse. I understand
> the time constraints for not making any changes right now but I the
> reuse of equivalentClass should be reconsidered after LC. Considering
> a lot of people coming from RDF world sees only the RDF view of OWL I
> think it is important to provide clear, consistent RDF mapping that
> does not lead to confusion.

An important part of the "deal" when we decided to introduce datatype
definitions was that there will be no change to the RDF-Based Semantics: for the
solution proposed, the semantic conditions on owl:equivalentClass were
sufficient. It is my understanding that the implementors of RDF-based systems
are rather leery of extending the RDF vocabulary, and it is particularly the
case when existing vocabulary suffices. As a consequence, the existing solution
is an extensively "negotiated" compromise between what the WG considered
necessary, correct, and "beautiful".

I am personally quite leery of reopening this can of worms, as it might have a
significant impact on the WG schedule. This is particularly so given that the
existing solution, while possibly being ugly, does work. Should you strongly
feel that we should revisit this decision, it would be really useful if you
could attend one of our teleconferences and "present your case".



Received on Wednesday, 8 April 2009 13:05:40 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:42:11 UTC