W3C home > Mailing lists > Public > public-owl-comments@w3.org > May 2009

RE: [LC response] To Jeremy Carroll Re: new comment: reification vocab

From: Jeremy Carroll <jeremy@topquadrant.com>
Date: Mon, 18 May 2009 09:40:16 -0700
To: "'Michael Schneider'" <schneid@fzi.de>
Cc: <public-owl-comments@w3.org>
Message-ID: <003901c9d7d7$531e6090$f95b21b0$@com>

Thank you - we are happy with this response

Jeremy

> -----Original Message-----
> From: Michael Schneider [mailto:schneid@fzi.de]
> Sent: Monday, May 18, 2009 5:02 AM
> To: jeremy@topquadrant.com
> Cc: public-owl-comments@w3.org
> Subject: [LC response] To Jeremy Carroll Re: new comment: reification
> vocab
> 
> Dear Jeremy,
> 
> Thank you for your comment
>      <http://lists.w3.org/Archives/Public/public-owl-
> comments/2009May/0016.html>
> on the OWL 2 Web Ontology Language last call drafts.
> 
> The Working Group is unwilling to use the RDF reification vocabulary
> because of the uncertainty of the intended meaning of RDF reification
> and the resulting strong negative views concerning its use.
> 
> The Working Group also feels that owl:subject, owl:predicate, and
> owl:object
> serve a different purpose than rdf:subject, rdf:predicate, and
> rdf:object.
> The terms are part of a new annotation framework in OWL 2, and the
> purpose
> of the terms is to provide a technical means for annotating certain
> kinds
> of OWL 2 axioms and other annotations in OWL 2. The usage of these
> terms
> is intended to be restricted to annotation tasks in OWL 2, only. Note
> also
> that the scope of an annotation in OWL 2 is an OWL 2 axiom or
> OWL 2 annotation, which will often be encoded by more than one RDF
> triple.
> 
> Nevertheless, the Working Group acknowledges that the currently used
> terms
> "owl:subject", "rdf:predicate", and "rdf:object" can easily be confused
> with
> the terms of the RDF reification vocabulary. The Working Group will
> therefore change the names of the terms in the following way:
> 
>   owl:subject   --> owl:annotatedSource
>   owl:predicate --> owl:annotatedProperty
>   owl:object    --> owl:annotatedTarget
> 
> The Working Group believes that this change will clarify the intended
> restricted usage of the terms and will also help to avoid confusion
> with
> the RDF reification vocabulary.
> 
> The Working Group considers this renaming of the terms to be a means
> to improve the clarity of the specification, and does not consider it
> as a change to the current design of OWL 2.
> 
> Please acknowledge receipt of this email to
> <mailto:public-owl-comments@w3.org> (replying to this email should
> suffice). In your acknowledgment please let us know whether or not
> you are satisfied with the working group's response to your comment.
> 
> Regards,
> Peter F. Patel-Schneider and Michael Schneider
> on behalf of the W3C OWL Working Group
Received on Monday, 18 May 2009 16:41:00 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 18 May 2009 16:41:01 GMT