Re: Using enums to avoid default true in "settings dictionaries" (#466, #467, #471)

On 2/23/16 4:16 AM, Adam Bergkvist wrote:
> On RTCDataChannel we have an oredered attribute, that reflects the
> ordered setting used to create the object. If we want to be consistent
> on the type it gets a bit strange if people try to use it as a boolean
> (which the name suggests it is).
>
> var dc = pc.createDataChannel(label, {ordered: "unordered"});
>
> !!pc.ordered is true (since !!"unordered" is true)

Generally, naming an enum after one of its possible choices seems poor, 
so if we switch ordered to be an enum we should probably call it 
something else. That way, there should be no confusion with the ordered 
attribute.

How about "order"? Not different enough?

.: Jan-Ivar :.

Received on Tuesday, 23 February 2016 15:31:21 UTC