W3C home > Mailing lists > Public > public-media-annotation@w3.org > April 2010

RE: [mawg] Update API document

From: Chris Poppe <Chris.Poppe@ugent.be>
Date: Tue, 27 Apr 2010 12:37:50 +0200
To: <public-media-annotation@w3.org>
Message-ID: <01ae01cae5f5$afb7d890$0f2789b0$@Poppe@ugent.be>
Dear all,

 

A second update has been made for this document based on the discussions of
this morning.

 

Kind regards,

Chris

 

From: public-media-annotation-request@w3.org
[mailto:public-media-annotation-request@w3.org] On Behalf Of Chris Poppe
Sent: dinsdag 27 april 2010 9:30
To: public-media-annotation@w3.org
Subject: [mawg] Update API document 

 

Dear all,

 

I have updated the API-document according to (some of ) the comments of
Sylvia. A new version can be found at:

http://dev.w3.org/2008/video/mediaann/mediaont-api-1.0/mediaont-api-1.0-resp
ec.html

 

I still need to finish all the javascript examples and include the examples
for the different methods (e.g. getPropertyNamesWithValues)

 

Some important comments that were not yet addressed:

 

6. Section 2.3.2.1 Contributor

 

* why are we suddenly using "id" and "role" as attribute values? They

should continue to be "value" and "type" like in the previous

properties for consistency.

 

[CP] Interesting, it might indeed be a good way for consistency although

the

use of "id" seemed more appropriate to me than "value" when talking about

contributors. I leave this open for the group.

 

7. Section 2.3.2.2 Creator

 

* replace "StringObject" with "Creator"

 

[CP] StringObject was used for each property that just holds a string. It

might indeed be better to define appropriate interfaces.

Will change this if the group agrees.

 

8. Section 2.3.2.3 CreationDate

 

* you talk about both "CreationDate" and "Date" here. If you want this

value to have a type of e.g. "creation date" and "publish date", it

should not be called "CreationDate", but only "Date".

[CP] I agree that "createDate" as propertyname is not a good name to

represent both "Create Date" and "Publish Date" subtypes. I am not fond of

the use of "date" as propertyname either since it sounds a bit too

generic.

 

 

Kind regards,
Chris

 

Ghent University - IBBT
Faculty of Engineering
Department of Electronics and Information Systems (ELIS)
Multimedia Lab Gaston Crommenlaan 8 bus 201
B-9050 Ledeberg-Ghent
Belgium

 
t: +32 9 33 14959
f: +32 9 33 14896
t secr: +32 9 33 14911
e:  <mailto:chris.poppe@ugent.be> chris.poppe@ugent.be

 

URL:  <http://multimedialab.elis.ugent.be>
http://multimedialab.elis.ugent.be

 
Received on Tuesday, 27 April 2010 10:38:25 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 27 April 2010 10:38:26 GMT