W3C home > Mailing lists > Public > public-ldp-wg@w3.org > January 2013

Re: ISSUE-37 WAS:Proposal for containers

From: Nandana Mihindukulasooriya <nmihindu@fi.upm.es>
Date: Thu, 31 Jan 2013 19:31:31 +0100
Message-ID: <CAAOEr1mCYxePMZSBhvtw1heis7hdEVewmpzCm+x60wVhZfrXEA@mail.gmail.com>
To: "public-ldp-wg@w3.org" <public-ldp-wg@w3.org>
Hi Steve,

On Thu, Jan 31, 2013 at 6:20 PM, Steve Battle <steve.battle@sysemia.co.uk>wrote:
>
>
> My proposal is then:
>
> 1) To specify ldp:contains (alternatively ldp:owns, ldp:manages) as the
> DEFAULT composition predicate. See section 5.2.5
> 2) Rename ldp:membershipPredicate as ldp:compositionPredicate, to clarify
> that this is refers to composition rather than aggregation.
> 3) Change EXAMPLE 1 to use ldp:contains, and EXAMPLE 5 to use something
> other than rdfs:member
>

Yes, I think in several previous threads people agreed that rdfs:member
might not be the best predicate to use for composition and it could lead to
confusions.

IMHO, we could open a separate issue (as this can be
settled independently from ISSUE-37) on the tracker to "change the default
predicate of an LDPC" to any of the three that the WG  agrees on. This way
it would be easier to see whether people agree or not with this proposal
and also we could do the necessary modifications to the specification if
people agree.

Best Regards,
Nandana
Received on Thursday, 31 January 2013 18:32:23 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:11:44 UTC