W3C home > Mailing lists > Public > public-ldp-wg@w3.org > January 2013

RE: ISSUE-37 WAS:Proposal for containers

From: Steve Battle <steve.battle@sysemia.co.uk>
Date: Thu, 31 Jan 2013 17:20:23 -0000
Message-ID: <f5ff95717309a54a5f746541439d3f1a@mail.gmail.com>
To: Raúl García Castro <rgarcia@fi.upm.es>, public-ldp-wg@w3.org
You make a good point that this is (almost entirely) consistent with the
existing spec, and that we should give users the option (enough rope) to
change this with ldp:membershipPredicate.

However, the current spec (section 5.2.5) states that rdfs:member is the

The first example we come across in the current spec
<http://www.w3.org/TR/2012/WD-ldp-20121025/> (EXAMPLE 1) uses rdfs:member
as the default membership predicate, and so risks confusing the reader
(about composition and aggregation) from the outset. EXAMPLE 5 is
similarly misleading.

My proposal is then:

1) To specify ldp:contains (alternatively ldp:owns, ldp:manages) as the
DEFAULT composition predicate. See section 5.2.5
2) Rename ldp:membershipPredicate as ldp:compositionPredicate, to clarify
that this is refers to composition rather than aggregation.
3) Change EXAMPLE 1 to use ldp:contains, and EXAMPLE 5 to use something
other than rdfs:member


> -----Original Message-----
> From: Raúl García Castro [mailto:rgarcia@fi.upm.es]
> Sent: 31 January 2013 08:42
> To: Steve Battle
> Cc: public-ldp-wg@w3.org
> Subject: Re: Proposal for containers
> El 30/01/13 20:18, Steve Battle escribió:
> > Ashok,
> >
> > LDP resources (including containers) are defined as "web resources
> > that describe their state using RDF". What are your thoughts on how
> > the relationship between the container and the contained is
> > represented in RDF? This being part of it's state.
> >
> > My concern, as always, is that if predicates like rdfs:member are
> > allowed for composition then this makes it difficult to distinguish
> > between a resource POSTed to the container (as in B.), and a resource
> > _linked_ to the container using rdfs:member (as in F.). I advocate use
> > of a distinct composition property (eg. ldp:contains, or ldp:owns, or
> > ldp:manages) to avoid this confusion between composition and
> > aggregation.
> >
> > This is an extension of your proposal below, NOT an alternative
> > proposal.
> Hi,
> I agree with Steve, we need to distinguish between protocol properties
> non-protocol ones, which entails not using rdfs:member as a default
> membership property.
> The current specification already covers this (changing the property
> name) and is consistent with Ashok's summary:
> .- Use ldp:contains (or any other name in the ldp namespace) as the
> property to represent the members of a container.
> .- Use ldp:membershipPredicate if you want to change the default
> membership property.
Received on Thursday, 31 January 2013 17:20:58 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:11:44 UTC