W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > February 2012

[Bug 16136] Requiring a "plugin" for <embed> is not compatible with <embed> pointing to SVG

From: <bugzilla@jessica.w3.org>
Date: Mon, 27 Feb 2012 16:50:32 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1S23mS-00069q-N4@jessica.w3.org>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=16136

--- Comment #1 from Boris Zbarsky <bzbarsky@mit.edu> 2012-02-27 16:50:32 UTC ---
Specifically, I believe <embed> pointing to SVG creates a child browsing
context in browsers, whereas the current spec text requires that no child
browsing context ever be created for <embed>....

Gecko's behavior for <embed> is that it's only handled via plug-ins (in the "no
child browsing context" sense, though they also happen to be NPAPI plug-ins)
except for "image/svg+xml" when it creates a child browsing context.  I haven't
tested other browsers extensively to see what their behavior is.

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Monday, 27 February 2012 16:50:40 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 27 February 2012 16:50:41 GMT