W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > November 2011

[Bug 14762] Rename all callbackInterface.handleEvent methods to something which describes what the method is about

From: <bugzilla@jessica.w3.org>
Date: Fri, 11 Nov 2011 22:26:24 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1ROzYG-0003Za-MA@jessica.w3.org>

Ian 'Hixie' Hickson <ian@hixie.ch> changed:

           What    |Removed                     |Added
             Status|REOPENED                    |NEW

--- Comment #4 from Ian 'Hixie' Hickson <ian@hixie.ch> 2011-11-11 22:26:24 UTC ---
handleEvent() seems quite sane to me, at least insofar as using an object with
a method instead of a closure is sane at all, which is another matter.

Using different names here would mean that one could not simply use the same
callback mechanism for all callbacks, which seems like a loss. It's not clear
what benefit there is in using different names; the only place one would see
these names is in the very place that passes the callback, where it's pretty
unambiguous what's going on anyway.

Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 11 November 2011 22:26:30 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 16:31:22 UTC