W3C home > Mailing lists > Public > public-forms@w3.org > July 2009

Re: [dialog element] need another name for "visible" attribute

From: Mark Birbeck <mark.birbeck@webbackplane.com>
Date: Thu, 30 Jul 2009 12:40:31 +0200
Message-ID: <ed77aa9f0907300340o6e1cde8au457f5a0490e8f26d@mail.gmail.com>
To: Nick Van den Bleeken <Nick_Van_den_Bleeken@inventivegroup.com>
Cc: John Boyer <boyerj@ca.ibm.com>, "public-forms@w3.org" <public-forms@w3.org>
Hi Nick,

> I'm a bit concerned with using the attribute appearance for something more as
> a rendering hint. Correct my if I'm wrong, but is appearance until now not just a
> hint to the user agent about how the control could be rendered. I.e. it doesn't
> drives the availability of a UI control, for your case a 'splashpage' it probably
> doesn't matter if the dialog isn't showed at all. In the case we were talking about
> on the phone, a modeless dialog that needs be shown at startup, it probably
> would matter if the dialog is shown or not, so ignoring the appearance attribute
> may make a form unusable.


> Here is a link to what we currently have http://www.w3.org/MarkUp/Forms/wiki/Dialog

...the @close value is based on the value of @appearance. So if you
can ignore @appearance, you could in theory end up with an uncloseable

Anyway, the key point I'm making is that rather than creating very
literal attributes, that precisely define some behaviour, we might
consider asking why we want the behaviour in the first place, and see
if we can't put a layer over it.

To me, an attribute that means 'make a dialog visible after
xforms-ready' seems very techie. It requires you to understand dialogs
and 'xforms-ready', which in turn requires that you understand events.

An attribute value that means 'this dialog is a splash-page', only
requires you to understand dialogs.

How we achieve that is of course a separate question. We've talked in
the past about using @role to indicate the *purpose* of an element,
which is 'stronger' than the hint provided by @appearance.

By the way, I'm not saying this is the only solution. I'm merely
saying that we might want to go one level up, rather than simply
looking for another name for @visible.

But another solution would be to simply use @selected, from
switch/case -- it at least has the advantage of consistency.

Anyway, just some thoughts. :)



Mark Birbeck, webBackplane



webBackplane is a trading name of Backplane Ltd. (company number
05972288, registered office: 2nd Floor, 69/85 Tabernacle Street,
London, EC2A 4RR)
Received on Thursday, 30 July 2009 10:41:17 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:14:01 UTC