W3C home > Mailing lists > Public > public-dwbp-wg@w3.org > December 2015

Re: Issue raised (was Re: [Time sensitive] property names)

From: Antoine Isaac <aisaac@few.vu.nl>
Date: Wed, 16 Dec 2015 13:42:18 +0100
Message-ID: <56715C2A.5060602@few.vu.nl>
To: Public DWBP WG <public-dwbp-wg@w3.org>
This is perfect, Phil. Thanks!

Antoine

On 12/16/15 12:45 PM, Phil Archer wrote:
> Unless someone objects - and more or less immediately - I'm going to insert an issue into the doc as can be seen at
>
> http://w3c.github.io/dwbp/vocab-dqg.html#h-issue4
>
> This would allow us to go ahead with the publication tomorrow.
>
> Phil
>
> On 15/12/2015 20:42, Antoine Isaac wrote:
>> Hi Phil,
>>
>> Technically the group the group has approved something with dqv:metric
>> so we can do many things :p
>> More seriously: I hope my mail was clear that at this stage, I don't
>> have any preference, and I'm quite frustrated not to have any clear
>> idea, what is best.
>> I'll see if I can come up with a note&issue that would reflect this, and
>> then you can tell me if it can be included or not.
>> In the meantime of course the group is more than welcome to chime in on
>> the matter of these property names!
>>
>> Cheers,
>>
>> Antoine
>>
>> On 12/15/15 5:45 PM, Phil Archer wrote:
>>> Agh!
>>>
>>> I've *just* finished getting the doc installed and ready at
>>> http://www.w3.org/TR/2015/WD-vocab-dqv-20151217/
>>>
>>> If you, as editor, want to stop the publishing process - and I can see
>>> that you have good grounds for doing so, Antoine, then so be it - at
>>> this stage it can still be deleted.
>>>
>>> And I could add a note/issue at this stage too, but no more than that
>>> since the WG approved the doc for publication in last week's call.
>>>
>>> Please advise.
>>>
>>> I'm about to go offline as I am about to head for an airport, but will
>>> be at home tomorrow and can act accordingly.
>>>
>>> Cheers
>>>
>>> Phil.
>>>
>>> On 15/12/2015 16:21, Antoine Isaac wrote:
>>>> Hi everyone,
>>>>
>>>> Thanks for the hard work on the final version. I'm going to try and help
>>>> for the deadline...
>>>>
>>>> As for the naming I'm partly guilty last week after Phil gave the turtle
>>>> file, I did some changes turning some dqv:hasMetric into dqv:metric. And
>>>> I may have failed getting them all (though I can't find a wrong
>>>> dqv:hasMetric in my last version)
>>>> The reason for this was to keep consistency with the property we inherit
>>>> from daQ. daq:metric leads to daq:Metric. And indeed there is a
>>>> daq:hasMetric that is quite different and that we have not re-used
>>>> directly (we instead created an inverse property, which is
>>>> dqv:hasDimension)
>>>>
>>>> Now if we have dqv:hasMetric equivalent to daq:metric this could be also
>>>> confusing, has we're not following the daQ naming convention (and we use
>>>> a 'local name' that is already in daQ but with different semantics!).
>>>>
>>>> This being said I understand Phil's point about the property convention:
>>>> I also prefer the convension :hasX for a property and :X for class.
>>>>
>>>> The problem is that daQ inherits their convention from the W3C DataCube
>>>> vocabulary, and that we also still have some references to
>>>> property/classes that follow the :x/:X pattern, such as
>>>> qb:dataSet/qb:Dataset.
>>>>
>>>> Is there any W3C best practice we could refer to to make one choice or
>>>> the other? Something like 'use :hasX unless your property is equivalent
>>>> to an already named ex:x' would be lovely, but I guess it doesn't exist.
>>>>
>>>> And that's the DUV stance on this? At least we could have homogeneity
>>>> within the group.
>>>>
>>>> A final comment: I don't think we need to make a final call for the WDs
>>>> to be published on Thursday, but I feel at least we should register an
>>>> issue about it if we don't have a decision everyone is ok with.
>>>>
>>>> Cheers,
>>>>
>>>> Antoine
>>>>
>>>> On 12/15/15 3:19 PM, Riccardo Albertoni wrote:> IMO, when speaking
>>>> about  DQV property :hasMetric is  Ok, whilst  :metric is  wrong.
>>>> :Metric is a class. We have   to pay extra attention  when it comes to
>>>> DAQ,  daq:hasMetric and daq:metric are  both valid properties and
>>>> defined as distinct.
>>>>>
>>>>> I did not know about the capitalization issue in  Japanese,  anyway,
>>>>> we can change the convention if the group thinks it is needed.
>>>>>
>>>>> Cheers,
>>>>> Riccardo
>>>>>
>>>>> On 15 December 2015 at 14:15, Phil Archer <phila@w3.org
>>>>> <mailto:phila@w3.org>> wrote:
>>>>>
>>>>>     Thank you, Riccardo, I'll do final processing later today.
>>>>>
>>>>>     Just a final check, :hasMerit is correct and :merit is incorrect?
>>>>> (I prefer the has version as there is clearly a class of :Merit and I
>>>>> don't like the convention of lower case properties leading to upper
>>>>> case classes - not only is it confusing for everyone, it doesn't work
>>>>> in languages like Japanese where there is no concept of letter case.
>>>>>
>>>>>     Phil.
>>>>>
>>>>>
>>>>>     On 15/12/2015 12:55, Riccardo Albertoni wrote:
>>>>>
>>>>>         Hi Phil and Jeremy,
>>>>>         I have updated the diagram,  added dqv:hasQualityMeasure in
>>>>> the ttl and
>>>>>         html, and   generated a new diff and published snapshot.
>>>>>
>>>>>         You find the updated versions on github.
>>>>>
>>>>>
>>>>>         On 15 December 2015 at 07:08, Phil Archer <phila@w3.org
>>>>> <mailto:phila@w3.org>> wrote:
>>>>>
>>>>>             Thanks again, Riccardo,
>>>>>
>>>>>             I've been through the document this morning and made some
>>>>> changes that I
>>>>>             need you to check over please.
>>>>>
>>>>>             First of all, I found references to the property metric
>>>>> and hasMetric. To
>>>>>             make things consistent I have changed all instances of
>>>>> dqv:metric to
>>>>>             dqv:hasMetric. If this is correct, all well and good. If
>>>>> it should be
>>>>>             dqv:metric, they'll all need changing back again.
>>>>>
>>>>>
>>>>>         It is ok thanks a lot for this, I have updated the diagram
>>>>> accordingly.
>>>>>
>>>>>
>>>>>             I reflected this change in the ttl file too - which I have
>>>>> uploaded to
>>>>>             w3.org/ns <http://w3.org/ns> so the namespace works. OK?
>>>>> I've removed the relevant note from
>>>>>             the doc as a result.
>>>>>
>>>>>
>>>>>         perfect!
>>>>>
>>>>>
>>>>>
>>>>>             All sections must have ids!
>>>>>
>>>>>             Again for consistency, I've made the id for each of the
>>>>> sections that
>>>>>             define a term into dqv:{term} rather than class:{term}
>>>>> etc. And updated
>>>>>             internal links accordingly.
>>>>>
>>>>>             many thanks for this.
>>>>>
>>>>>
>>>>>
>>>>>             I can't find a definition for dqv:hasQualityMeasure - that
>>>>> seems to be
>>>>>             missing. Can you either add that to the doc and the ttl
>>>>> file please or
>>>>>             remove it where it is mentioned in both?
>>>>>
>>>>>             Added both in ttl and html.
>>>>>
>>>>>
>>>>>
>>>>>             I think that's all.
>>>>>
>>>>>             Sorry to push but the doc needs to be ready for
>>>>> publication during
>>>>>             tomorrow, Wednesday, so time is very limited.
>>>>>
>>>>>             Cheers
>>>>>
>>>>>             Phil.
>>>>>
>>>>>             Let me know if you see other issues.
>>>>>
>>>>>
>>>>>         Thanks again,
>>>>>         Riccardo
>>>>>
>>>>>
>>>>
>>>>
>>>
>>
>>
>
Received on Wednesday, 16 December 2015 12:42:50 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 16 December 2015 12:42:50 UTC