W3C home > Mailing lists > Public > public-device-apis@w3.org > December 2009

Re: Callback naming

From: Ilkka Oksanen <Ilkka.Oksanen@nokia.com>
Date: Wed, 02 Dec 2009 13:44:48 +0200
Message-ID: <4B165330.8070000@nokia.com>
To: ext Robin Berjon <robin@berjon.com>
CC: "public-device-apis@w3.org" <public-device-apis@w3.org>
ext Robin Berjon wrote:
> E.g.:
> PendingOperation captureDahut (in CaptureCallback successCallback, in
> optional ErrorCallback errorCallback);
> replaced by
> PendingOp captureDahut (in CaptureCB successCB, in optional ErrorCB
> errorCB);

I think this is a good idea. These names will propably appear in every 
API so it shouldn't be a big burden for the reader to figure them out 
once (if not evident immediately).

There is related issue conserning SuccessCallback, ErrorCallback and 
PendingOperation interfaces. In camera API those interfaces are copied 
from Richard's Contact API draft. Would it be possible to create common 
parts specification or something similar for them to get rid of copy 
paste WebIDL?

Received on Wednesday, 2 December 2009 11:45:43 UTC

This archive was generated by hypermail 2.3.1 : Monday, 23 October 2017 14:53:41 UTC