RE: getSimplePropertyValue

Stick with getSimplePropertyValues. It wouldn't make any sense to say
getUnknownSimplePropertyValues, so the "Known" is redundant.

 

Plus people don't always have the luxury of programming in widescreen.

 

As the semantics of the 4th method are subtly different, perhaps calling
it getPropertyValues would be enough, because the second parameter
clearly indicates that it is Simple Properties being requested, and the
same method could later be overloaded in an advanced API by passing an
array of PropertyRef objects instead of SimplePropertyRef objects.

 

It's just a thought. I don't really mind one way or the other.

 

---R

 

From: public-ddwg-request@w3.org [mailto:public-ddwg-request@w3.org] On
Behalf Of Jo Rabin
Sent: 26 February 2008 14:52
To: public-ddwg@w3.org
Subject: getSimplePropertyValue

 

At the moment we have 4 overloaded calls:

 

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence)

                  throws SystemException;

 

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence,

                  String aspectIRI, String aspectName) throws
NameException,

                  SystemException;

 

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence,

                  String aspectName) throws NameException,
SystemException;

      

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence,

                  SimplePropertyRef[] properties) throws NameException,

                  SystemException;

 

 

 

I think it would be better if the first 3 were called
getKnownSimplePropertyValues  since the semantic is different from the
following which returns values for all specified propoerties?

 

Any views before I post an updated interface definition?

 

Jo

 

Received on Tuesday, 26 February 2008 15:04:43 UTC