getSimplePropertyValue

At the moment we have 4 overloaded calls:

 

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence)

                  throws SystemException;

 

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence,

                  String aspectIRI, String aspectName) throws
NameException,

                  SystemException;

 

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence,

                  String aspectName) throws NameException,
SystemException;

      

      public SimplePropertyValues getSimplePropertyValues(SimpleEvidence
evidence,

                  SimplePropertyRef[] properties) throws NameException,

                  SystemException;

 

 

 

I think it would be better if the first 3 were called
getKnownSimplePropertyValues  since the semantic is different from the
following which returns values for all specified propoerties?

 

Any views before I post an updated interface definition?

 

Jo

 

Received on Tuesday, 26 February 2008 14:52:39 UTC