W3C home > Mailing lists > Public > public-css-testsuite@w3.org > November 2014

Re: Building writing-modes test suite: linking to #propdef-writing-mode instead #writing-mode

From: Peter Linss <peter.linss@hp.com>
Date: Thu, 20 Nov 2014 18:46:35 -0800
Cc: Public CSS Test suite mailing list <public-css-testsuite@w3.org>
Message-Id: <A486E6F5-A224-42AB-883A-5B7987C5879A@hp.com>
To: Gérard Talbot <css21testsuite@gtalbot.org>
I found and fixed the problem, the test indexer was mis-sorting the tests, causing some tests not linked to a section heading to be placed into the wrong sections in the index file. The indexes should be accurate starting with tonight's build.

Peter

On Nov 19, 2014, at 6:48 PM, Peter Linss <peter.linss@hp.com> wrote:

> Hmmm, strange, both Shepherd and the test harness see those tests in section 3.1, so it must be a bug in the build code while building the index page. I'll look in to it tomorrow, don't bother changing the tests.
> 
> Peter
> 
> On Nov 19, 2014, at 6:36 PM, Gérard Talbot <css21testsuite@gtalbot.org> wrote:
> 
>> Peter,
>> 
>> In this 3.1.1 subsection
>> 
>> http://test.csswg.org/suites/css-writing-modes-3_dev/nightly-unstable/html/chapter-3.htm#s3.1.1
>> 
>> there are 11 tests which have nothing to do with SVG.
>> 
>> 3.1.1 SVG1.1 writing-mode Values
>> http://www.w3.org/TR/css-writing-modes-3/#svg-writing-mode
>> 
>> If I consider this test,
>> 
>> http://test.csswg.org/suites/css-writing-modes-3_dev/nightly-unstable/html/writing-mode-vertical-rl-001.htm
>> 
>> it is linked to #propdef-writing-mode instead #writing-mode
>> 
>> More explicitly:
>> 
>> <link rel="help" title="CSS3 Writing modes: 3.1. Block Flow Direction: the 'writing-mode' property" href="http://www.w3.org/TR/css-writing-modes-3/#propdef-writing-mode">
>> 
>> should be instead
>> 
>> <link rel="help" title="CSS3 Writing modes: 3.1. Block Flow Direction: the 'writing-mode' property" href="http://www.w3.org/TR/css-writing-modes-3/#writing-mode">
>> 
>> Now the building of the test suite puts such test (and the other 10 tests) in section 3.1.1 while they should be, in all fairness, in section 3.1. This causes me some annoyance as I do not know how many tests are really about section 3.1 and now many tests are really about section 3.1.1 ... and the same phenomenon may be happening in other sections of Writing modes test suite and in other test suites!
>> 
>> I'd be willing to edit those 11 tests and remove "propdef-" ... unless you tell me that you can do something or should modify how the test suites are built...
>> 
>> Gérard
>> -- 
>> Test Format Guidelines
>> http://testthewebforward.org/docs/test-format-guidelines.html
>> 
>> Test Style Guidelines
>> http://testthewebforward.org/docs/test-style-guidelines.html
>> 
>> Test Templates
>> http://testthewebforward.org/docs/test-templates.html
>> 
>> CSS Naming Guidelines
>> http://testthewebforward.org/docs/css-naming.html
>> 
>> Test Review Checklist
>> http://testthewebforward.org/docs/review-checklist.html
>> 
>> CSS Metadata
>> http://testthewebforward.org/docs/css-metadata.html
> 


Received on Friday, 21 November 2014 02:47:02 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:13:27 UTC