W3C home > Mailing lists > Public > public-css-testsuite@w3.org > November 2012

Re: [css3-background]Tests with SVG can’t run because the SVG files are missing

From: Gérard Talbot <css21testsuite@gtalbot.org>
Date: Sun, 04 Nov 2012 00:35:08 -0400
Message-ID: <20121104003508.28764qi4lqajrbzw@ed-sh-cp3.entirelydigital.com>
To: Emmanuel Vallois <emmanuel@vallois.name>
Cc: Public CSS test suite mailing list <public-css-testsuite@w3.org>
Gérard Talbot <css21testsuite@gtalbot.org> a écrit :

> Gérard Talbot <css21testsuite@gtalbot.org> a écrit :
>> Emmanuel Vallois <emmanuel@vallois.name> a écrit :
>>> Hi,
>>> All the tests listed on  
>>> http://test.csswg.org/harness/results/CSS3-BACKGROUND_DEV/grouped/  
>>> in section 3.9 starting from  
>>> “diagonal-percentage-vector-background” need SVG files to run.  
>>> Trying to get these files return a 404 error, so these tests are  
>>> currently unusable.
>> Hello Emmanuel,
>> I confirm your findings.
>> http://test.csswg.org/suites/css3-background/nightly-unstable/html4/chapter-3.htm#s3.9
>> "
>> This is a Pre-Alpha version of the CSS Backgrounds and Borders  
>> Module Level 3 Test Suite.
>> Some tests in the test suite may contain errors.
>> "
>> http://test.csswg.org/suites/css3-background/nightly-unstable/
>>> I would therefore suggest that after fixing the presence of SVG  
>>> files, the current results filed for these tests be dismissed or  
>>> tagged as invalid, as they couldn’t test anything.
>>> Wishing to be useful,
>>> Emmanuel Vallois
>> Agreed.
>> I do not know who is managing CSS3 background right now, making  
>> sure that all linked references are correct.
>> Jeff Walden CSS3 background tests in section 3.9 with SVG flag:
>> 207 tests
>> http://test.csswg.org/shepherd/search/testcase/spec/CSS3-BACKGROUND/author/jeff_walden/flag/svg/load/t207/
>> If you load tests individually from within Shepherd, the SVG files  
>> are linked, fetched correctly.
>> E.g.:
>> http://test.csswg.org/shepherd/testcase/tall--auto--nonpercent-width-percent-height/
>> and then click on the Test tab. So, the SVG files exist: they just  
>> do not seem to be linked correctly during built.
> Emmanuel,
> I believe I understand what is happening here.
> The tests, the SVG files and the reference files are all in the same folder:
> http://test.csswg.org/source/contributors/mozilla/submitted/css3-background/background-size/vector/
> when the SVG files should be instead in a /support and the reftests  
> should be in an /reference subfolders instead.


I created a /support and a /reference sub-folders under


and edited this test:


and then moved the relevant files

ref-tall-lime256x384-aqua256x384.html into /reference


omitted-width-omitted-height.svg into /support

and then edited the test so that the .svg and .html are properly  
linked. Locally, the links of the test work.

I also edited a bit the test so that the linked spec is according to  
format guidelines and removed the null end tags which is not needed in  

committed changeset 4724:c28c772f3b0a

Tonight, after the built of the CSS3 background test suite, I will  
check if these changes were successful. If they were, then


should be properly linked to the svg image and the reference file  
should be fetchable too.

If this works for tall--auto--omitted-width-omitted-height.htm , then  
someone (not sure who, probably me, I guess) will have to edit the  
other 206 tests from Jeff Walden according to such set of adjustments.

Contributions to the CSS 2.1 test suite:

CSS 2.1 Test suite RC6, March 23rd 2011

CSS 2.1 test suite harness:
Received on Sunday, 4 November 2012 04:35:38 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:13:25 UTC