W3C home > Mailing lists > Public > public-css-testsuite@w3.org > November 2012

Re: [css3-background]Tests with SVG can’t run because the SVG files are missing

From: Gérard Talbot <css21testsuite@gtalbot.org>
Date: Sat, 03 Nov 2012 20:54:58 -0400
Message-ID: <20121103205458.17602dcnom54bpb6@ed-sh-cp3.entirelydigital.com>
To: Emmanuel Vallois <emmanuel@vallois.name>
Cc: Public CSS test suite mailing list <public-css-testsuite@w3.org>
Gérard Talbot <css21testsuite@gtalbot.org> a écrit :

> Emmanuel Vallois <emmanuel@vallois.name> a écrit :
>
>> Hi,
>>
>> All the tests listed on  
>> http://test.csswg.org/harness/results/CSS3-BACKGROUND_DEV/grouped/  
>> in section 3.9 starting from  
>> “diagonal-percentage-vector-background” need SVG files to run.  
>> Trying to get these files return a 404 error, so these tests are  
>> currently unusable.
>
> Hello Emmanuel,
>
> I confirm your findings.
>
> http://test.csswg.org/suites/css3-background/nightly-unstable/html4/chapter-3.htm#s3.9
>
> "
> This is a Pre-Alpha version of the CSS Backgrounds and Borders  
> Module Level 3 Test Suite.
> Some tests in the test suite may contain errors.
> "
> http://test.csswg.org/suites/css3-background/nightly-unstable/
>
>
>> I would therefore suggest that after fixing the presence of SVG  
>> files, the current results filed for these tests be dismissed or  
>> tagged as invalid, as they couldn’t test anything.
>>
>> Wishing to be useful,
>>
>> Emmanuel Vallois
>
> Agreed.
>
> I do not know who is managing CSS3 background right now, making sure  
> that all linked references are correct.
>
> Jeff Walden CSS3 background tests in section 3.9 with SVG flag:
>
> 207 tests
>
> http://test.csswg.org/shepherd/search/testcase/spec/CSS3-BACKGROUND/author/jeff_walden/flag/svg/load/t207/
>
>
> If you load tests individually from within Shepherd, the SVG files  
> are linked, fetched correctly.
>
> E.g.:
> http://test.csswg.org/shepherd/testcase/tall--auto--nonpercent-width-percent-height/
> and then click on the Test tab. So, the SVG files exist: they just  
> do not seem to be linked correctly during built.

Emmanuel,

I believe I understand what is happening here.

The tests, the SVG files and the reference files are all in the same folder:

http://test.csswg.org/source/contributors/mozilla/submitted/css3-background/background-size/vector/


when the SVG files should be instead in a /support and the reftests  
should be in an /reference subfolders instead.



>
> Adding, hopefully, Jeff Walden to this email, ... mostly because  
> these are his tests.

I've tried to reach Jeff Walden but the email bounced back.

Salutations amicales de Montréal,

Gérard
-- 
Contributions to the CSS 2.1 test suite:
http://www.gtalbot.org/BrowserBugsSection/css21testsuite/

CSS 2.1 Test suite RC6, March 23rd 2011
http://test.csswg.org/suites/css2.1/20110323/html4/toc.html

CSS 2.1 test suite harness:
http://test.csswg.org/harness/
Received on Sunday, 4 November 2012 00:55:30 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 4 November 2012 00:55:32 GMT