W3C home > Mailing lists > Public > public-comments-wcag20@w3.org > February 2008

H36: Using alt attributes on images used as submit buttons

From: Christophe Strobbe (on behalf of BenToWeb) <christophe.strobbe@esat.kuleuven.be>
Date: Fri, 01 Feb 2008 21:14:32 +0100
Message-Id: <6.2.5.6.2.20080201205443.02d372c0@esat.kuleuven.be>
To: public-comments-wcag20@w3.org

Hi,

This comment and the following ones result from work in the BenToWeb 
project (http://www.bentoweb.org/).


When we developed test case sc1.1.1_l1_240 [1], we discovered that 
the test procedure defines no requirements for the alt text. The 
description states: "This label indicates the button's function, but 
does not attempt to describe the image." However, the test procedure 
only checks for the presence of the alt attribute.

Proposal:

* Add a second step: "Check that the alt attribute indicates the 
button's function."

* Update the expected results: "#1 and #2 are true".

(This comment was previously submitted at 
http://lists.w3.org/Archives/Public/public-comments-wcag20/2007Sep/0003.html.)

[1] http://bentoweb.org/ts/XHTML1_TestSuite3/metadata/sc1.1.1_l1_240

Best regards,

Christophe Strobbe


-- 
Christophe Strobbe
K.U.Leuven - Dept. of Electrical Engineering - SCD
Research Group on Document Architectures
Kasteelpark Arenberg 10 bus 2442
B-3001 Leuven-Heverlee
BELGIUM
tel: +32 16 32 85 51
http://www.docarch.be/ 


Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm
Received on Friday, 1 February 2008 20:15:00 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 17 July 2011 06:13:24 GMT