[Bug 20764] It makes no sense to use EventListener for onaudioprocess if ScriptProcessorNode isn't EventTarget

https://www.w3.org/Bugs/Public/show_bug.cgi?id=20764

--- Comment #5 from Ehsan Akhgari [:ehsan] <ehsan@mozilla.com> ---
(In reply to comment #4)
> (In reply to comment #3)
> > Also, in that case, we should rename onaudioprocess for consistency as well.
> 
> This would be a breaking API change for shipping versions, so we'd have to
> be careful to move it to the "deprecated" and recommended section if we
> thought it important to change.  Personally, I don't think there's any
> reason it can't still be called onaudioprocess even though it has nothing to
> do with EventListener

webkit can still support the old API I guess, but the onXXX naming convention
is used throughout the web platform for things using event targets, and using
such a naming scheme will be very surprising to all web developers, so I think
that is a really bad idea.

Also the usage of callbacks can enable us clean up the API by accepting the
callback as an argument to the createScriptProcessor function, which makes it
unnecessary to expose it on ScriptProcessorNode at all.  Speaking of which, I
don't think exposing bufferSize on that node type makes much sense either.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.

Received on Tuesday, 19 February 2013 06:12:02 UTC