W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2012

[Bug 20505] merge getInput, getOutput -> getPort() or getPortById()

From: <bugzilla@jessica.w3.org>
Date: Wed, 26 Dec 2012 17:00:30 +0000
To: public-audio@w3.org
Message-ID: <bug-20505-5429-YLd01vEpgN@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=20505

--- Comment #5 from Chris Wilson <cwilso@gmail.com> ---
(In reply to comment #4)
> Just wanted to record a random thought here:
> 
> getPort(DOMString id, optional MIDIPortType type);
> 
> As in: 
> var port = midi.getPort("12e23f3", "input");

But why would you do that? For any given id, the type is predetermined (and
fixed).  If you were going down this path (of collapsing Input and Output
together), I would expect:

interface MIDIAccess {
    sequence<MIDIPort> listInputs ();
    sequence<MIDIPort> listOutputs ();
    MIDIPort          getPort (MIDIPort or DOMString or short target);
};

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
Received on Wednesday, 26 December 2012 17:00:31 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:50:04 UTC