W3C home > Mailing lists > Public > public-appformats@w3.org > November 2006

Re: [Widgets] Brief feedback

From: Gorm Haug Eriksen <gormer@opera.com>
Date: Fri, 10 Nov 2006 12:52:10 +0100
To: "Marcos Caceres" <m.caceres@qut.edu.au>, "Ed Voas" <voas@yahoo-inc.com>
Cc: public-appformats@w3.org
Message-ID: <op.tistw8gcm2jbu9@id-c0364.oslo.opera.com>

On Fri, 10 Nov 2006 06:44:23 +0100, Marcos Caceres <m.caceres@qut.edu.au>  

> I also agree with Ed in relation to the root node maybe being called  
> something other than <widget> (for the sake of accommodating all  
> vendors). Some alternative names off the top of my head:
> * <application>, or
> * <component>, or
> * <about>, or
> * <manifest>, or
> * <metadata>, or
> * <configuration>
> Anyone else got any suggestions?

Yea, widget isn't a good name. Perhaps <config> since the file is called  

> Given that the Widgets 1.0 is based on Opera's config format for their  
> widgets, I cannot comment as to why or how Opera uses <width> and  
> <height>.

They are used for the initial width and height of the window. Personally,  
I think we should have used CSS styling to determine aspect. I agree with  
Ed that it shouldn't be part of the format.

Other comments:

- <widgetname> should be renamed to <name>
- should support multiple authors
- the security tag should be dropped or reviewed
- should not require that a widget is packaged at the root of the zip file
- The Widget Scripting Interfaces should be dropped or reviewed. In  
particular, the geometry methods since this wouldn't make sense on some  
widget runners
- should mention a XML NS for the format
- should mention a strategy for both embedding the config information  
inside the widget and reference the config information from the widget


- Gorm Haug Eriksen
Received on Friday, 10 November 2006 11:52:41 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:50:05 UTC