W3C home > Mailing lists > Public > html-tidy@w3.org > January to March 2000

Re: HTML Tidy pages are failing to display in Mozilla M14

From: Steve Rauch <srauch@u.washington.edu>
Date: Fri, 24 Mar 2000 11:47:56 -0600
To: Karl Ove Hufthammer <huftis@bigfoot.com>
Cc: "P. T. Rourke" <ptrourke@mediaone.net>, html-tidy@w3.org
Message-ID: <OF3E058034.DAD1BEDF-ON862568A8.005D25A0@rfdinc.com>

> > All pages that I have created in HTML-Tidy output as XHTML
> Transitional are
> > failing to display in Mozilla M14 for Win98, as is the page
> > http://www.w3.org/MarkUp/ .
>
> Well, this is actually namespace bug in Mozilla. Don't worry about -- it
> will be fixed soon (there already exists several bug reports about XHTML
> support in Moz).
>

While I cannot speak to the cause of this problem in Mozilla, I do know it
is not limited to Mozilla. I have seen the same problem in M14 on NT and
Linux. Although viewing source shows the HTML file, it does not display in
the browser. But a problem was first pointed out to me by someone running
IE4.5 on a Macintosh. His browser displayed the raw source code.

In all cases, the page could be displayed correctly in the browser by
removing the xml declaration on line 1 of the file.

Since IE4.5 is a freely distributed production version of a browser, I
have had to back off my plans to convert all my html files to
xhtml. Actually, I have been converting them to xhtml, and then removing
the xml declaration.

Sorry, this is probably not a problem with tidy, but perhaps not too for
afield for  the tidy list.

Steve Rauch    srauch@u.washington.edu
UW Academic Medical Center Website Manager
Received on Friday, 24 March 2000 14:13:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 3 April 2012 06:13:43 GMT