OS/2 port for w3c library and samples ?


I just downloaded the source for the w3c library, comline, linemode,
etc with the intention of porting to OS/2.
After a couple of hours I was able to get the library and comline to
compile and comline linked and worked ok, eventually - I initially
used it to access a local file which yielded a 'stack overflow'. This
I later learned is a bug in the w3c library, having been mentioned in
another post to this list. Requests to my local HTTPD and FTPD seemed
to work fine.
I then tried to get linemode to work. It compiled and linked ok but I
am currently unable to get it do anything useful. 

Before I dive into the source/debugger has anyone else ported the
library and sample programs  to OS/2 (and got them working) ? 

Incidently I am using the Watcom v10.0a compiler and IBM's TCP/IP
(IAK) (with the headers from IBM's TCP/IP developers kit) running on
OS/2 Warp.

Also are there any plans to add OS/2 to the list of supported
platforms ?


  Stephen Summerfield                   
  at home                      
  Norwich, UK                    "It must be true - I read 
  s.summerfield@dial.pipex.com          it on the net"